2022年 11月 8日

linux中下载python_linux下python安装

一、安装相关依赖

yum install gcc patch libffi-devel python-devel  zlib-devel bzip2-devel openssl-devel ncurses-devel sqlite-devel readline-devel tk-devel gdbm-devel db4-devel libpcap-devel xz-devel -y

二、安装python

(1)wget https://www.python.org/ftp/python/3.6.3/Python-3.6.3.tgz  下载安装包 (可以到网站下载,然后上传到Linux)

(2)/usr/local 下新建文件夹python3

(3)tar -zxvf Python-3.6.3.tgz  解压安装包

(4)cd Python-3.6.3   转到该安装包目录下

(5)./configure –prefix=/usr/local/python3  这一步及其重要,对安装进行配置,并指定安装路径,安装路径不指定的话不利于后面的系统管理

(6)make 编译

(7)make install 安装

安装成功

a94536b59e4ad81e84d7fc8f9b9615ee.png

(8) cd /usr/local/python3n  进入python3目录

(9)ls bin/  查看python3.7的可执行脚本文件

fa1b91a85f0e23337d57beabc5bc0aa4.png

(10)添加环境变量:(此处我没有添加软链接,按需添加)

1,添加软连接(用法):

ln -s 源文件路径 目标文件路径

2,添加变化软连接:

ln -s /usr/local/python3/bin/python3.6 /usr/bin/python3

3,添加pip3软连接:

ln -s /usr/local/python3/bin/pip3.6 /usr/bin/pip3

(11)将/usr/local/python3/bin加入PATH

vim /etc/profile

然后在文件末尾添加

export PATH=$PATH:/usr/local/python3/bin

source /etc/profile

(12)此处就不要操作了,更改后,使用yum会报错

修改以下俩个配置文件:

第一行修改为(#! /usr/bin/python3)即可

vim /usr/libexec/urlgrabber-ext-down

vim /usr/bin/yum

python -V (查看python版本)

大功告成。

如果不安装依赖,会报如下错误

报错:zipimport.ZipImportError: can’t decompress data; zlib not available

make: *** [install] Error 1